• COMUNICADO: O fórum será atualizado dia 29/01/2022, iniciando às 08:00 da manhã, com previsão de finalizar o processo até às 20:00. Nesse intervalo o fórum ficará fechado para mensagens. Assim que o processo for finalizado, liberaremos novamente o acesso.

Tutorial como colocar o modem da vivo fibra em bridge sem que o telefone e a tv deixem de funcionar

dudu1505

¯\(ツ)/¯
Registrado
Atualizando a minha saga. Consegui fazer a interatividade funcionar, assim como o "Ver desde o inicio". PORÉM o vídeo ao vivo trava após uns segundos :mad:

O que mudei dessa vez:

Nas configurações avançadas da HGU removi todas as VLANS da WAN (Menos a VOIP) e criei duas novas VLANS, 600 com prioridade 0 (Internet) e 602 com prioridade 3. Ambas em modo BRIDGE. Desativei o DHCP da LAN.

fqBhLjI.jpg


No PfSense deixei duas NICs para a HGU, dois cabos de rede ligados. Criei uma Interface WAN em PPPoE e outra Interface WAN-IPTV em DHCP. Consegui conectar a Internet e pegar o IP Interno do VoD (10.x.x.x/8).

LUhS8VN.jpg


Sim, estou mostrando o IP externo. Provavelmente ele já mudou nesse momento que escrevo.

Habilitei o IGMP Proxy para os seguintes IPs:

O IP 192.168.100.0/24 é minha LAN Interna

StbSvE8.jpg


Criei uma nova LAN-IPTV com as seguintes regras:

mlyRC8l.jpg


O ALIAS IPTV_IPs são os IPs que citei antes. 201.0.52.1 a 201.0.52.254, 177.16.30.1 a 177.16.30.254, 177.16.26.53, 177.16.26.54 e 172.28.0.32. Eles somente são reconhecidos pela Interface WANIPTV (10.x.x.x/8), tudo que sai da LANIPTV para esses IPs são redirecionados para o Gateway obtido na WANIPTV.

Bom, passei o sábado inteiro tentando fazer isso funcionar. Mas não consegui completamente. Como disse, agora tudo funciona, porém a TV Ao Vivo funciona por 10seg e apresenta uma mensagem de erro
cara se tiver mais uma porta nic física no pfsense coloca um decoder direto nela e associa essa porta para tua rede lan, e roda o coletor de pacotes do pfsense só na porta fisica, depois é analisar no wireshark

basicamente fazer isso aqui com o nic extra par ao ponta da tv: https://docs.netgate.com/pfsense/en/latest/book/packetcapture/using-wireshark-with-pfsense.html

só assim pra descobrir o que qui o decoder esta tentando acessar e não esta obtendo resposta.
 

mcsj

New Member
Registrado
cara se tiver mais uma porta nic física no pfsense coloca um decoder direto nela e associa essa porta para tua rede lan, e roda o coletor de pacotes do pfsense só na porta fisica, depois é analisar no wireshark

basicamente fazer isso aqui com o nic extra par ao ponta da tv: https://docs.netgate.com/pfsense/en/latest/book/packetcapture/using-wireshark-with-pfsense.html

só assim pra descobrir o que qui o decoder esta tentando acessar e não esta obtendo resposta.

Tentei isso. Mas simplesmente não da nenhum erro ou falta de resposta no Wireshark. Simplesmente para de responder repentinamente.

Se tiver disposição, até tenho a captura de pacotes aqui.



------ EDIT -----

Agora fiquei na dúvida se estava falando para capturar com as modificações que fiz ou se era para capturar com o modem e tvbox nas configurações padrões.

Se for para as configurações padrões, até tentei fazer esse processo de captura com outro PC e 3 NICs, mas a tvbox simplesmente não funciona. Usei esse vídeo como processo


 
Última edição:

dudu1505

¯\(ツ)/¯
Registrado
Tentei isso. Mas simplesmente não da nenhum erro ou falta de resposta no Wireshark. Simplesmente para de responder repentinamente.

Se tiver disposição, até tenho a captura de pacotes aqui.



------ EDIT -----

Agora fiquei na dúvida se estava falando para capturar com as modificações que fiz ou se era para capturar com o modem e tvbox nas configurações padrões.

Se for para as configurações padrões, até tentei fazer esse processo de captura com outro PC e 3 NICs, mas a tvbox simplesmente não funciona. Usei esse vídeo como processo


a ideia inicial que dei era pensando em captar com as modificações que vc fez msm, pra ver o que rola entre o pfsense e o decoder, no caso pra ver se o decoder tenta se comunicar com algum ip e não tem retorno e por isso trava tudo.

mas parando pra pensar bem, o ideal é captar o trafego com a config original do modem da vivo e do decoder, fazer basicamente isso aqui:
modem vivo -> aqueles HUB antigo que trabalha em broadcast -> decoder tv.

com isso é questão de ligar numa das portas do hub o pc com wireshark e literalmente escutar TUDO o que rola de comunicação entre modem original e decoder tv.

e se tiver um wireshark dos dois modos, pode ate facilitar na procura, pq certamente no modo de config com pfsense vai faltar alguma comunicação.

é praticamente um ataque man in the middle que tem que ser feito :haha:

----------------

pra falar a verdade, não me lembro se funciona mas, se não me engano se vc pegar 3 cabos de rede corta eles e unir 3 pontas com as cores respectivas no esquema de ligação 10base-t(só usa os pares verdes e laranja), teoricamente vc "cria" um hub passivo.

a e a escuta no pfsense não é usando suricate, é basicamente é a mesma escuta que seria feita com o hub mas de forma mais "elegante" por assim dizer.
mas tb funcionaria no caso de usar o mesmo esquema de pfsense -> hub -> decoder tv, desse jeito tu escuta o trafego no pc direto no wireshark através do hub.
só não me lembro se é questão de só fazer essa gambiarra com os cabos ou se tb tem que usar alguma ligação com diodos.

a @mcsj só me fala ae, qual o ip do decoder nessa captura que tu mando? é o 192.168.100.101?
 
Última edição:

dudu1505

¯\(ツ)/¯
Registrado
@mcsj

cara pela captura que tu mando, da pra dizer que o range de ip 177.16.30.1 a 177.16.30.254, são os servidores que enviam o sinal do VOD em si, tem praticamente só conteúdo saindo do ip 177.16.30.252 indo em direção ao decoder 192.168.100.101 via udp.

ta faltando realmente só descobrir os hosts que fazem a autenticação do decoder periodicamente, e possivelmente jogar o trafego deles pra vlan da tv.

-----------

a e um extra que tem nessa tua captura, tem algumas requisições em texto plano http :haha:
literalmente dando get nessas urls, via o ip 200.146.72.232, que retornam uma imagem em png:
Código:
80    0.097932    192.168.100.101    200.146.72.232    HTTP    381    GET /customer/v1/source/seo-tag?width=234&resize=CROP&height=132&format=PNG&image=http://media.gvp.telefonica.com/storagearea0/IMAGES/00/07/35/7356339_2A8710C402FF864E.jpg HTTP/1.1

e esse ip 200.146.72.232, cara sei la o que tem nele mas ele responde na internet aberta.
sera que é esse servidor que gera as thumbnail dos canais pra exibir nos decoders?
 

mcsj

New Member
Registrado
@mcsj

cara pela captura que tu mando, da pra dizer que o range de ip 177.16.30.1 a 177.16.30.254, são os servidores que enviam o sinal do VOD em si, tem praticamente só conteúdo saindo do ip 177.16.30.252 indo em direção ao decoder 192.168.100.101 via udp.

ta faltando realmente só descobrir os hosts que fazem a autenticação do decoder periodicamente, e possivelmente jogar o trafego deles pra vlan da tv.

Isso! Esse é o range do VOD Ao Vivo, o range das "reprises" e itens gravados é o 201.0.52.0/24.

177.16.30.252 era o IP na ocasião da captura, esse IP muda de acordo com vários fatores.

a e um extra que tem nessa tua captura, tem algumas requisições em texto plano http :haha:
literalmente dando get nessas urls, via o ip 200.146.72.232, que retornam uma imagem em png:
Código:
80    0.097932    192.168.100.101    200.146.72.232    HTTP    381    GET /customer/v1/source/seo-tag?width=234&resize=CROP&height=132&format=PNG&image=http://media.gvp.telefonica.com/storagearea0/IMAGES/00/07/35/7356339_2A8710C402FF864E.jpg HTTP/1.1

e esse ip 200.146.72.232, cara sei la o que tem nele mas ele responde na internet aberta.
sera que é esse servidor que gera as thumbnail dos canais pra exibir nos decoders?

Ai que está o detalhe, para a IPTV funcionar 100% você precisa ter acesso a Internet "convencional" e ao mesmo tempo IPs específicos para o VOD que apenas são acessíveis pela VLAN da IPTV. Os thumbnails vem pela Internet.
--- Post duplo é unido automaticamente: ---

a ideia inicial que dei era pensando em captar com as modificações que vc fez msm, pra ver o que rola entre o pfsense e o decoder, no caso pra ver se o decoder tenta se comunicar com algum ip e não tem retorno e por isso trava tudo.

mas parando pra pensar bem, o ideal é captar o trafego com a config original do modem da vivo e do decoder, fazer basicamente isso aqui:
modem vivo -> aqueles HUB antigo que trabalha em broadcast -> decoder tv.

com isso é questão de ligar numa das portas do hub o pc com wireshark e literalmente escutar TUDO o que rola de comunicação entre modem original e decoder tv.

e se tiver um wireshark dos dois modos, pode ate facilitar na procura, pq certamente no modo de config com pfsense vai faltar alguma comunicação.

é praticamente um ataque man in the middle que tem que ser feito :haha:

Rapaz! Acho que tem uns 20 anos que não vejo um HUB kkkkkkkkkk

pra falar a verdade, não me lembro se funciona mas, se não me engano se vc pegar 3 cabos de rede corta eles e unir 3 pontas com as cores respectivas no esquema de ligação 10base-t(só usa os pares verdes e laranja), teoricamente vc "cria" um hub passivo.

a e a escuta no pfsense não é usando suricate, é basicamente é a mesma escuta que seria feita com o hub mas de forma mais "elegante" por assim dizer.
mas tb funcionaria no caso de usar o mesmo esquema de pfsense -> hub -> decoder tv, desse jeito tu escuta o trafego no pc direto no wireshark através do hub.
só não me lembro se é questão de só fazer essa gambiarra com os cabos ou se tb tem que usar alguma ligação com diodos.

Acho meio arriscado. Não sei se quero arriscar meu switch, é um L2 rsrsrs.

a @mcsj só me fala ae, qual o ip do decoder nessa captura que tu mando? é o 192.168.100.101?

Isso! Nessa ocasião esse era o IP do decoder
--- Post duplo é unido automaticamente: ---

uma dúvida conseguiu rodar Netflix pelo decoder ?

Não tentei. Mas da forma descrita no post inicial do tópico é praticamente certeza que não vai funcionar.
 

dudu1505

¯\(ツ)/¯
Registrado
Isso! Esse é o range do VOD Ao Vivo, o range das "reprises" e itens gravados é o 201.0.52.0/24.

177.16.30.252 era o IP na ocasião da captura, esse IP muda de acordo com vários fatores.



Ai que está o detalhe, para a IPTV funcionar 100% você precisa ter acesso a Internet "convencional" e ao mesmo tempo IPs específicos para o VOD que apenas são acessíveis pela VLAN da IPTV. Os thumbnails vem pela Internet.
--- Post duplo é unido automaticamente: ---



Rapaz! Acho que tem uns 20 anos que não vejo um HUB kkkkkkkkkk


--- Post duplo é unido automaticamente: ---



Não tentei. Mas da forma descrita no post inicial do tópico é praticamente certeza que não vai funcionar.
ou o hub passivo tem que fazer isso aqui: https://www.hardware.com.br/dicas/hubs-passivos.html
img-492a8e19.gif


com esse esquema, e essa porrada de diodos da pra ligar sem risco que queimar as portas ethernet :haha:

foda que encontrar um hub vagabundo hj é ate dificio, e quem iria imaginar que ele que seria o método pra interceptar a conexão do decoder da vivo pra pegar as configs e se livrar do modo router do modem :haha::haha::haha::haha::haha::haha::haha::haha::haha::haha:

--------------

hum, pensando aqui, não me lembro bem mas se não me engano tem como configurar o pfsense como uma ponte entre a 2 nics distintos, desse jeito da pra descartar o uso do hub.
pq o próprio pfsense vai capturar o trafego entre o modem da vivo e o decoder.
 

NuK3 DoOM

New Member
Registrado
Eu tenho um Router Dlink Layer 3, mas é tão ruim que não consigo separar as vlans.
Encomendei um HP Aruba sem gerenciamento, vou adicionar na minha rede um router asus com suporte a IP TV. Vou tentar pegar as informações do Mitra e jogar no Asus para ver o que da.
Só desligar o DHCP no Mitra já mata a TV. Vou fazer o tuto e posto como ficou. Chegando o Aruba, vamos ver se consigo fazer todas as rotas funcionarem.
Obrigado pela dica
 

albertoacj

New Member
Registrado
O foda que essas rodas mudam né teria que ficar sempre atualizando isso, o ideal seria que todo conteúdo fosse pela VLAN da iptv...
 

tecpix

Always Newbie
Registrado
Lembro de ter visto duas pessoas que conseguiram eliminar o equipamento da Vivo com TV usando roteadores próprios. Um havia feito usando OpenWRT e outro parece que havia conseguido usando um Asus-AC86U.

Em ambos os casos a tentativa foi muito mais pelo desafio do que pela necessidade

Infelizmente ambos tutoriais estavam no HTForum. Eu havia salvado o link para o tutorial do Asus, mas com o fechamento do HTForum ele ficou inacessível: https://www.htforum.com/forum/threads/clube-vivo-fibra-tv-ftth.199673/page-898
Torcer para que o database do HtForum seja limpo e novamente aberto para consulta.

O do OpenWRT é de 2013 e eu tinha salvo aqui.. Não cheguei a tentar pois no fim vi que não valeria a pena tanto esforço para o benefício que poderia ter usando DMZ.

Mas vou tentar colocar abaixo.

=======================================
Substituindo Sagemcom por Tp-Link Archar c7 V2 (OpenWRT)

Para a configuracao deste roteador, serao necessarios os seguintes itens:
Putty: https://the.earth.li/~sgtatham/putty/latest/w32/putty.exe
OpenWRT: https://downloads.openwrt.org/snaps...1xx-generic-archer-c7-v2-squashfs-factory.bin

Apos a instalacao do OpenWRT, utilizando o putty, conecte-se via SHH no IP: 192.168.1.1
Sera solicitado um usuario: root, mas ainda sem senha.
Por padrao, estaa distribuicao do OpenWRT vem sem o ambiente grafico e sem o driver do wireless de 5GHz.
Conecte a porta WAN do Archer C7 em qualquer porta LAN do Sagemcom e rode os seguintes comentos:

opkg update
opkg install ath10k-firmware-qca988x igmpproxy luci

Ja vamos efetuar as configuracoes necessarias, nao disponiveis na interface grafica
As alteracoes estao em negrito:

vi /etc/config/igmpproxy
config igmpproxy
option quickleave 1
# option verbose [0-2]

config phyint wan
option network 'IPTV'
option direction upstream
list altnet 0/0

config phyint lan
option network lan
option direction downstream

Adicionar as seguintes linahs para a correta informacao do DNS server para os decodificadores:

vi /etc/dnsmasq.conf
dhcp-host=xx:xx:xx:xx:xx:xx,set:stb
dhcp-option=tag:stb,option:dns-server,172.29.130.5,172.29.130.6

Sendo que xx:xx:xx:xx:xx:xx corrsponde ao MAC address de um de seus decodificadores. Caso tenha mais de 1 decodificador, adicione quantas linhas ‘dhcp-host=xx:xx:xx:xx:xx:xx,set:stb' forem necessarias

Habilite o igmpproxy para iniciar automaticamente

/etc/init.d/igmpproxy enable

Reinicie o roteador, usando o comando ‘reboot’ e plugue a WAN do mesmo na ONT, feche o Putty e as proximas configuracoes serao via browser

cesse o endereco: http://192.168.1.1
Na parte superior da tela, havera um aviso para configurar a senha do root, clique no link ‘password configuration...’


Informe a senha desejada e clique em ‘Save and Apply’

Va em ‘Network – Firewall’ e adicione uma nova zona, como mostrado abaixo:

upload_2017-6-12_11-43-51.png

Clique em ‘save and Apply’

Va em ‘Network – Interfaces’ e exclua as interfaces WAN e WAN6, a configuracao devera ficar igual a tela abaixo:

upload_2017-6-12_11-44-14.png

Va em ‘Network – Switch’ e configure de forma a ficar semelhante a tela abaixo:

upload_2017-6-12_11-44-35.png

Clique em ‘Save and Apply’

Va em Network – Interfaces
Iremos adicionar duas novas interfaces: IPTV e INTERNET
Clique em ‘Add new Interface’
Namo: IPTV
Protocol: Static address
Interface: eth0.20
upload_2017-6-12_11-45-15.png


Clique em ‘Submit’

Na tela que se segue, informe o endereco IP, mascara de subrede, gateway e servidores DNS, em seguida clique em ‘Firewall Settings’ e escolha a zona ‘IPTV, clique em ‘Save and Apply’

upload_2017-6-12_11-45-36.png


Clique novamente em ‘Add new Interface’
Namo: INTERNET
Protocol: PPPoE
Interface: eth0.10
upload_2017-6-12_11-46-3.png


Clique em Submit

Informe o usuario e senha do PpoE ([email protected]/cliente no meu caso) e clique em Firewall Settings e escolha a opcao WAN
upload_2017-6-12_11-46-24.png


Clique em ‘Save and Apply’

A partir deste momento a internet ja estara disponivel e as interfaces estarao da seguinte forma:

upload_2017-6-12_11-46-58.png

Va em ‘Network – Static Routes e adicione as rotas conforme mostrado abaixo. Somente substitua o gateway de acordo com a sua configuracao:
upload_2017-6-12_11-47-13.png


Clique em ‘Save and Apply’

Reinicie o roteador em 'System - Reboot', plugue seus decodificadores e divirta-se.
As configuracoes da rede sem fio, ficarao por sua conta, mas e so ir em 'Network - Wireless'
 

s1Qu31R4

Ethical
Registrado
um otimo tutorial, quando eu voltar pra casa, testarei o bridge....

comentario para acompanhar o topico !!
 

mcsj

New Member
Registrado
Lembro de ter visto duas pessoas que conseguiram eliminar o equipamento da Vivo com TV usando roteadores próprios. Um havia feito usando OpenWRT e outro parece que havia conseguido usando um Asus-AC86U.

Em ambos os casos a tentativa foi muito mais pelo desafio do que pela necessidade

Infelizmente ambos tutoriais estavam no HTForum. Eu havia salvado o link para o tutorial do Asus, mas com o fechamento do HTForum ele ficou inacessível: https://www.htforum.com/forum/threads/clube-vivo-fibra-tv-ftth.199673/page-898
Torcer para que o database do HtForum seja limpo e novamente aberto para consulta.

O do OpenWRT é de 2013 e eu tinha salvo aqui.. Não cheguei a tentar pois no fim vi que não valeria a pena tanto esforço para o benefício que poderia ter usando DMZ.

Mas vou tentar colocar abaixo.

=======================================
Substituindo Sagemcom por Tp-Link Archar c7 V2 (OpenWRT)

Para a configuracao deste roteador, serao necessarios os seguintes itens:
Putty: https://the.earth.li/~sgtatham/putty/latest/w32/putty.exe
OpenWRT: https://downloads.openwrt.org/snaps...1xx-generic-archer-c7-v2-squashfs-factory.bin

Apos a instalacao do OpenWRT, utilizando o putty, conecte-se via SHH no IP: 192.168.1.1
Sera solicitado um usuario: root, mas ainda sem senha.
Por padrao, estaa distribuicao do OpenWRT vem sem o ambiente grafico e sem o driver do wireless de 5GHz.
Conecte a porta WAN do Archer C7 em qualquer porta LAN do Sagemcom e rode os seguintes comentos:

opkg update
opkg install ath10k-firmware-qca988x igmpproxy luci

Ja vamos efetuar as configuracoes necessarias, nao disponiveis na interface grafica
As alteracoes estao em negrito:

vi /etc/config/igmpproxy
config igmpproxy
option quickleave 1
# option verbose [0-2]

config phyint wan
option network 'IPTV'
option direction upstream
list altnet 0/0

config phyint lan
option network lan
option direction downstream

Adicionar as seguintes linahs para a correta informacao do DNS server para os decodificadores:

vi /etc/dnsmasq.conf
dhcp-host=xx:xx:xx:xx:xx:xx,set:stb
dhcp-option=tag:stb,option:dns-server,172.29.130.5,172.29.130.6

Sendo que xx:xx:xx:xx:xx:xx corrsponde ao MAC address de um de seus decodificadores. Caso tenha mais de 1 decodificador, adicione quantas linhas ‘dhcp-host=xx:xx:xx:xx:xx:xx,set:stb' forem necessarias

Habilite o igmpproxy para iniciar automaticamente

/etc/init.d/igmpproxy enable

Reinicie o roteador, usando o comando ‘reboot’ e plugue a WAN do mesmo na ONT, feche o Putty e as proximas configuracoes serao via browser

cesse o endereco: http://192.168.1.1
Na parte superior da tela, havera um aviso para configurar a senha do root, clique no link ‘password configuration...’


Informe a senha desejada e clique em ‘Save and Apply’

Va em ‘Network – Firewall’ e adicione uma nova zona, como mostrado abaixo:

upload_2017-6-12_11-43-51.png

Clique em ‘save and Apply’

Va em ‘Network – Interfaces’ e exclua as interfaces WAN e WAN6, a configuracao devera ficar igual a tela abaixo:

upload_2017-6-12_11-44-14.png

Va em ‘Network – Switch’ e configure de forma a ficar semelhante a tela abaixo:

upload_2017-6-12_11-44-35.png

Clique em ‘Save and Apply’

Va em Network – Interfaces
Iremos adicionar duas novas interfaces: IPTV e INTERNET
Clique em ‘Add new Interface’
Namo: IPTV
Protocol: Static address
Interface: eth0.20
upload_2017-6-12_11-45-15.png


Clique em ‘Submit’

Na tela que se segue, informe o endereco IP, mascara de subrede, gateway e servidores DNS, em seguida clique em ‘Firewall Settings’ e escolha a zona ‘IPTV, clique em ‘Save and Apply’

upload_2017-6-12_11-45-36.png


Clique novamente em ‘Add new Interface’
Namo: INTERNET
Protocol: PPPoE
Interface: eth0.10
upload_2017-6-12_11-46-3.png


Clique em Submit

Informe o usuario e senha do PpoE ([email protected]/cliente no meu caso) e clique em Firewall Settings e escolha a opcao WAN
upload_2017-6-12_11-46-24.png


Clique em ‘Save and Apply’

A partir deste momento a internet ja estara disponivel e as interfaces estarao da seguinte forma:

upload_2017-6-12_11-46-58.png

Va em ‘Network – Static Routes e adicione as rotas conforme mostrado abaixo. Somente substitua o gateway de acordo com a sua configuracao:
upload_2017-6-12_11-47-13.png


Clique em ‘Save and Apply’

Reinicie o roteador em 'System - Reboot', plugue seus decodificadores e divirta-se.
As configuracoes da rede sem fio, ficarao por sua conta, mas e so ir em 'Network - Wireless'


Aqui eu também estava fazendo mais pelo desafio do que pela necessidade. Reparei que o tutorial no OpenWRT parece ter sido feito por alguém que trocou o modem da VIVO por uma ONT pelas VLANs na WAN. Eu acho que é por isso que não avanço, os poucos que obtiveram sucesso estavam usando ONTs ao invés da HGU da VIVO.

Eu acredito que tenha dois problemas no meu caso, 1- Não tenho uma ONT e 2- Parece que o PfSense faz um péssimo trabalho com IGMP Proxy, essa reclamação é constante nos fóruns na gringa. Até tentei avançar com OpenWRT, antes de ver esse passo-a-passo. Mas também não consegui, mais pela incompreensão com o OpenWRT acredito eu. Seu Post me esclareceu uma dúvida, realmente a maior parte das configurações ainda são via linha de comando apesar da interface web LuCI.
 

NuK3 DoOM

New Member
Registrado
Eu segui o tutorial, coloquei o mitrastar em bridge e fiz meu Asus cuidar da conexão. Tenho um switch hpe para fazer toda a conexão com os cabos. Minha config:

Modem Mitrastar > Wan do Asus / lan do Asus > switch Hpe

Minha Internet deu um salto incrível de latência e velocidade. Tenho 300mb, esta batendo fácil 340 a 360 Mb. Nos jogos online meu ping está muito mais estável em trono de 5 no CS.

Único problema:
A TV ligada no mitrastar por cabo não conecta. Se ligo no switch ela conecta, mas assim que mudo de canal ela cai.

Sabem o que eu posso ter feito de errado?

EDIT: na verdade só funciona a Nickelodeon :confused:
 
Última edição:

tecpix

Always Newbie
Registrado
Eu segui o tutorial, coloquei o mitrastar em bridge e fiz meu Asus cuidar da conexão. Tenho um switch hpe para fazer toda a conexão com os cabos. Minha config:

Modem Mitrastar > Wan do Asus / lan do Asus > switch Hpe

Minha Internet deu um salto incrível de latência e velocidade. Tenho 300mb, esta batendo fácil 340 a 360 Mb. Nos jogos online meu ping está muito mais estável em trono de 5 no CS.

Único problema:
A TV ligada no mitrastar por cabo não conecta. Se ligo no switch ela conecta, mas assim que mudo de canal ela cai.

Sabem o que eu posso ter feito de errado?

EDIT: na verdade só funciona a Nickelodeon :confused:
Eu me lembro de ter visto uns 20 usuários no HtForum colocando a VLAN de internet em Bridge.. dos 20, 18 (eu inclusive) perderam a TV, seja por quadricular, VOD, troca de canais, etc...

Eu ACHO que existe diferentes formas da IPTV se comunicar com a internet. A maioria das instalações ainda usa não só a VLAN de TV mas também a VLAN de Internet para sincronia..
Algumas poucas instalações parece que não..

Acho que você está numa instalação que depende da VLAN de internet no Mitra.. assim, não poderia colocar em Bridge..
 

jackolino

New Member
Registrado
Eu não consigo entrar no /padrão. Pede o login e senha, e já tentei o que esta no modem, o cliente, e até do aplicativo.
 

NuK3 DoOM

New Member
Registrado
Eu me lembro de ter visto uns 20 usuários no HtForum colocando a VLAN de internet em Bridge.. dos 20, 18 (eu inclusive) perderam a TV, seja por quadricular, VOD, troca de canais, etc...

Eu ACHO que existe diferentes formas da IPTV se comunicar com a internet. A maioria das instalações ainda usa não só a VLAN de TV mas também a VLAN de Internet para sincronia..
Algumas poucas instalações parece que não..

Acho que você está numa instalação que depende da VLAN de internet no Mitra.. assim, não poderia colocar em Bridge..

Boa, pode ser isso mesmo, pq toda parte de aluguel e tal funciona.
Eu vou fazer o que estava discutindo no topico dedicado, por meu router interno em uma DMZ do Mitra e ver o que da
 

ALLANshindi

Member
Registrado
Boa noite pessoal!

Tenho uma duvida, nao é exatamente a do topico, mas confio na galera aqui.

Tenho um modem/roteador da Vivo, Mitrastar, e um roteador TPLink C6

O TPlink esta em um comodo distante do Vivo, e no modem da Vivo tem um PC conectado nele...

Existe como colocar o Modem da Vivo em bridge sem perder uma porta que esta ligado o PC?

Espero que tenha dado pra entender, estou com essa duvida pois estou com muito problema com Double NAT no Plex e NAS,
 

dudu1505

¯\(ツ)/¯
Registrado
Boa noite pessoal!

Tenho uma duvida, nao é exatamente a do topico, mas confio na galera aqui.

Tenho um modem/roteador da Vivo, Mitrastar, e um roteador TPLink C6

O TPlink esta em um comodo distante do Vivo, e no modem da Vivo tem um PC conectado nele...

Existe como colocar o Modem da Vivo em bridge sem perder uma porta que esta ligado o PC?

Espero que tenha dado pra entender, estou com essa duvida pois estou com muito problema com Double NAT no Plex e NAS,
não tem.

modo bridge passa a gerencia completa da rede pra o primeiro dispositivo a frente.
no caso vai dar problemas no caso de hora só tplink pegar a internet e hora só o pc pegar.
 

ALLANshindi

Member
Registrado
não tem.

modo bridge passa a gerencia completa da rede pra o primeiro dispositivo a frente.
no caso vai dar problemas no caso de hora só tplink pegar a internet e hora só o pc pegar.


putz, que merda :/ mas obrigado pela resposta
 

mcsj

New Member
Registrado
Desisti por completo de fazer a IPTV funcionar fora da HGU ou com ela em brigde. O ponto que não consegui transpassar foi o IGMP (Multicast). Por último, olhando com calma as configurações do meu modem, existem 4 VLANs. 600, 601, 602 e 4000. Reparei que apesar da VLAN 602 ser para VOD, o multicast vai para a VLAN 4000.

Cheguei a comprar a ONT TPLink TX-6610. Deixei ela como transparente, configurei todas as VLANs no PfSense, mandei os IPs do VOD sairem pela VLAN 602 e mandar tudo que fosse Multicast e IGPM para a VLAN 4000, mesmo assim não foi. Com isso esgotei todas as possibilidades e ideias que tinha em mente. Parei em um beco sem saída. Mandar o IGMP para a VLAN 602 também não funcionou.

O IPTV funciona por 5s e da uma mensagem de erro, até peguei raiva do erro kkkkkkkk

Pior que a Internet melhorou significativamente com a ONT da TPLink e não pode ser utilizada.
 
Última edição:

tecpix

Always Newbie
Registrado
Desisti por completo de fazer a IPTV funcionar fora da HGU ou com ela em brigde.
Bem vindo ao clube.. :true:

Desisti já lá em 2015, antes de virar modinha.. :haha:


Tem muita complexidade que só se consegue com firmware exclusivo pra tudo funcionar.. não vale o esforço..

Coloquei meu router como AP e sucesso!
 

fassumpcao

New Member
Registrado
Lembro de ter visto duas pessoas que conseguiram eliminar o equipamento da Vivo com TV usando roteadores próprios. Um havia feito usando OpenWRT e outro parece que havia conseguido usando um Asus-AC86U.

Em ambos os casos a tentativa foi muito mais pelo desafio do que pela necessidade

Infelizmente ambos tutoriais estavam no HTForum. Eu havia salvado o link para o tutorial do Asus, mas com o fechamento do HTForum ele ficou inacessível: https://www.htforum.com/forum/threads/clube-vivo-fibra-tv-ftth.199673/page-898
Torcer para que o database do HtForum seja limpo e novamente aberto para consulta.

O do OpenWRT é de 2013 e eu tinha salvo aqui.. Não cheguei a tentar pois no fim vi que não valeria a pena tanto esforço para o benefício que poderia ter usando DMZ.

Mas vou tentar colocar abaixo.

=======================================
Substituindo Sagemcom por Tp-Link Archar c7 V2 (OpenWRT)

Para a configuracao deste roteador, serao necessarios os seguintes itens:
Putty: https://the.earth.li/~sgtatham/putty/latest/w32/putty.exe
OpenWRT: https://downloads.openwrt.org/snaps...1xx-generic-archer-c7-v2-squashfs-factory.bin

Apos a instalacao do OpenWRT, utilizando o putty, conecte-se via SHH no IP: 192.168.1.1
Sera solicitado um usuario: root, mas ainda sem senha.
Por padrao, estaa distribuicao do OpenWRT vem sem o ambiente grafico e sem o driver do wireless de 5GHz.
Conecte a porta WAN do Archer C7 em qualquer porta LAN do Sagemcom e rode os seguintes comentos:

opkg update
opkg install ath10k-firmware-qca988x igmpproxy luci

Ja vamos efetuar as configuracoes necessarias, nao disponiveis na interface grafica
As alteracoes estao em negrito:

vi /etc/config/igmpproxy
config igmpproxy
option quickleave 1
# option verbose [0-2]

config phyint wan
option network 'IPTV'
option direction upstream
list altnet 0/0

config phyint lan
option network lan
option direction downstream

Adicionar as seguintes linahs para a correta informacao do DNS server para os decodificadores:

vi /etc/dnsmasq.conf
dhcp-host=xx:xx:xx:xx:xx:xx,set:stb
dhcp-option=tag:stb,option:dns-server,172.29.130.5,172.29.130.6

Sendo que xx:xx:xx:xx:xx:xx corrsponde ao MAC address de um de seus decodificadores. Caso tenha mais de 1 decodificador, adicione quantas linhas ‘dhcp-host=xx:xx:xx:xx:xx:xx,set:stb' forem necessarias

Habilite o igmpproxy para iniciar automaticamente

/etc/init.d/igmpproxy enable

Reinicie o roteador, usando o comando ‘reboot’ e plugue a WAN do mesmo na ONT, feche o Putty e as proximas configuracoes serao via browser

cesse o endereco: http://192.168.1.1
Na parte superior da tela, havera um aviso para configurar a senha do root, clique no link ‘password configuration...’


Informe a senha desejada e clique em ‘Save and Apply’

Va em ‘Network – Firewall’ e adicione uma nova zona, como mostrado abaixo:

upload_2017-6-12_11-43-51.png

Clique em ‘save and Apply’

Va em ‘Network – Interfaces’ e exclua as interfaces WAN e WAN6, a configuracao devera ficar igual a tela abaixo:

upload_2017-6-12_11-44-14.png

Va em ‘Network – Switch’ e configure de forma a ficar semelhante a tela abaixo:

upload_2017-6-12_11-44-35.png

Clique em ‘Save and Apply’

Va em Network – Interfaces
Iremos adicionar duas novas interfaces: IPTV e INTERNET
Clique em ‘Add new Interface’
Namo: IPTV
Protocol: Static address
Interface: eth0.20
upload_2017-6-12_11-45-15.png


Clique em ‘Submit’

Na tela que se segue, informe o endereco IP, mascara de subrede, gateway e servidores DNS, em seguida clique em ‘Firewall Settings’ e escolha a zona ‘IPTV, clique em ‘Save and Apply’

upload_2017-6-12_11-45-36.png


Clique novamente em ‘Add new Interface’
Namo: INTERNET
Protocol: PPPoE
Interface: eth0.10
upload_2017-6-12_11-46-3.png


Clique em Submit

Informe o usuario e senha do PpoE ([email protected]/cliente no meu caso) e clique em Firewall Settings e escolha a opcao WAN
upload_2017-6-12_11-46-24.png


Clique em ‘Save and Apply’

A partir deste momento a internet ja estara disponivel e as interfaces estarao da seguinte forma:

upload_2017-6-12_11-46-58.png

Va em ‘Network – Static Routes e adicione as rotas conforme mostrado abaixo. Somente substitua o gateway de acordo com a sua configuracao:
upload_2017-6-12_11-47-13.png


Clique em ‘Save and Apply’

Reinicie o roteador em 'System - Reboot', plugue seus decodificadores e divirta-se.
As configuracoes da rede sem fio, ficarao por sua conta, mas e so ir em 'Network - Wireless'

Este tutorial fui eu que postei no outro fórum, na época minha instalação da vivo tinha 2 equipamentos, a ONT (Blue castle) e o roteador Sagemcom.

Nas versões mais atuais do OpenWrt a configuração do igmpproxy mudou um pouco, depois posto aqui.

Antes que me esqueça, esse tutorial foi baseado na plataforma de TV Mediaroom, que tenho até hoje.
 

mcsj

New Member
Registrado
Este tutorial fui eu que postei no outro fórum, na época minha instalação da vivo tinha 2 equipamentos, a ONT (Blue castle) e o roteador Sagemcom.

Nas versões mais atuais do OpenWrt a configuração do igmpproxy mudou um pouco, depois posto aqui.

Antes que me esqueça, esse tutorial foi baseado na plataforma de TV Mediaroom, que tenho até hoje.

Por favor! Não deixe de atualizar se ainda está funcionando.
--- Post duplo é unido automaticamente: ---

Bem vindo ao clube.. :true:

Desisti já lá em 2015, antes de virar modinha.. :haha:


Tem muita complexidade que só se consegue com firmware exclusivo pra tudo funcionar.. não vale o esforço..

Coloquei meu router como AP e sucesso!

Pensei ter mudado, pois antigamente a IPTV era via HPNA e pensei que dificultava mais. Como agora as TV BOX são ethernet, tentei me aprofundar.
 

NiceNike

New Member
Registrado
Perdão minha ignorância, mas tenho uma internet vivo e gostaria de saber oque é isto. Agradeco se alguém puder explicar.
 

Usuários que está vendo este tópico

Topo